Ask Your Question
0

Problems with uav_viewer

asked 2018-02-04 14:53:44 -0600

scarrion gravatar image

Dear all, I'm having troubles launching the uav_viewer tool. Could someone tell me the correct way to execute it? Thanks, Santi

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2018-02-04 15:13:58 -0600

jmplaza gravatar image

Hi Santi,

there are directions to launch uavviewer here

Cheers

edit flag offensive delete link more
0

answered 2018-02-04 15:24:07 -0600

scarrion gravatar image

Hi,

Running in that way I get the following error message, (I am working with the latest version of jderobot 5.6.2)

Traceback (most recent call last): File "./uav_viewer.py", line 23, in <module> import config File "/opt/jderobot/lib/python2.7/config/init.py", line 8, in <module> from .config import * File "/opt/jderobot/lib/python2.7/config/config.py", line 22, in <module> import yaml ImportError: No module named 'yaml'

edit flag offensive delete link more
0

answered 2018-02-05 13:40:14 -0600

fqez gravatar image

Hi!

do you have the yaml package installed in your system? sudo apt install python-yaml

edit flag offensive delete link more

Comments

yes, in fact I use it in other developments without problems >>python-yaml ya está en su versión más reciente (3.11-3build1).

scarrion gravatar imagescarrion ( 2018-02-05 13:55:10 -0600 )edit

Hi Santi, maybe you have python3 installed on your machine and it is the default interpreter. Try to run uav_viewer.py with the python2.7 interpreter: python2 /opt/jderobot/share/jderobot/python/uav_viewer_py/uav_viewer.py uav_viewer_py.yml We use 2.7 to be fully compatible with ROS-Kinect

jmplaza gravatar imagejmplaza ( 2018-02-10 13:41:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-02-04 14:53:44 -0600

Seen: 26 times

Last updated: Feb 05