Ask Your Question
0

Example 3.1 problems with roslaunch

asked 2018-01-30 18:22:20 -0600

nataliace gravatar image

Hi everyone,

I'm new with JdeRobot and I have problems trying the example 3.1. When and try to run Gazebo with roslaunch, like this:

roslaunch /opt/jderobot/share/jderobot/launch/kobuki-simple-ros.launch

some warnings appears:

Warning [parser.cc:527] Can not find the XML attribute 'version' in sdf XML tag for model: Ground Plane Transparent. Please specify the SDF protocol supported in the model configuration file. The first sdf tag in the config file will be used

and:

[ WARN] [1517352495.085263458]: Kobuki(ns = turtlebotROS/): missing <rosDebugLevel> default is na

Despite this the program starts, but when I run kobukiViewer with:

kobukiViewer kobukiViewer.yml

the next error appears:

Network.cpp:2357: Ice::ConnectionRefusedException:
connection refused: Connection refused
/usr/include/IceUtil/Handle.h:46: IceUtil::NullHandleException
!! 31/01/18 00:03:37.482 error: communicator not destroyed during global destruction.

and the process doesn't start. I already check the configuration file and it looks like the example says. Though running Gazebo like in the example 3.2 with:

gazebo kobuki-simple.world

the first warning also appears but when I run the kobukiViewer with:

kobukiViewer kobukiViewer.yml

everything works fine.

So my doubts are why I have this error with the first example? and what's the difference between call run Gazebo with ROS or directly?

Thanks in advance for your help!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-01-31 05:11:54 -0600

aitormf gravatar image

Hi,

your problems with this example are because we use 2 communicator middlewares (ROS messages and ICE). By default, our config files set ICE and in your first test you use ROS, but in second use ICE.

if you edit kobukiViewer.yml setting all Server to 2, kobukiViewer will use ROS and all will work fine:

kobukiViewer:
  Motors:
    Server: 2 # 0 -> Deactivate, 1 -> Ice , 2 -> ROS
    Proxy: "Motors:default -h localhost -p 9001"
    Topic: "/turtlebotROS/mobile_base/commands/velocity"
    Name: kobukiViewerMotors
    maxV: 3
    maxW: 0.7

  Camera1:
    Server: 2 # 0 -> Deactivate, 1 -> Ice , 2 -> ROS
    Proxy: "CameraL:default -h localhost -p 9001"
    Format: RGB8
    Topic: "/TurtlebotROS/cameraL/image_raw"
    Name: kobukiViewerCamera1

  Camera2:
    Server: 2 # 0 -> Deactivate, 1 -> Ice , 2 -> ROS
    Proxy: "CameraR:default -h localhost -p 9001"
    Format: RGB8
    Topic: "/TurtlebotROS/cameraR/image_raw"
    Name: kobukiViewerCamera2

  Pose3D:
    Server: 2 # 0 -> Deactivate, 1 -> Ice , 2 -> ROS
    Proxy: "Pose3D:default -h localhost -p 9001"
    Topic: "//turtlebotROS/odom"
    Name: kobukiViewerPose3d

  Laser:
    Server: 2 # 0 -> Deactivate, 1 -> Ice , 2 -> ROS
    Proxy: "Laser:default -h localhost -p 9001"
    Topic: "/turtlebotROS/laser/scan"
    Name: kobukiViewerLaser

  Vmax: 3
  Wmax: 0.7
  NodeName: kobukiViewer
edit flag offensive delete link more
0

answered 2018-02-01 08:44:42 -0600

jmplaza gravatar image

updated 2018-02-01 08:47:41 -0600

Hi Natalia,

this bug has already been solved in the github repository . The solution will be integrated in the upcoming debian package of JdeRobot that will be released (hopefully) next week.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-30 18:22:20 -0600

Seen: 100 times

Last updated: Feb 01