Ask Your Question
0

Having trouble in installing jderobot

asked 2018-01-18 10:58:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have been facing issues in installing Jderobot.I am mainly getting two errors

1)"ImportError: No module named Ice".This error is always showing when i try to compile with python2.7. 2)I am unable to run the python dependencies of jderobot with python3.5.I went to the following file "/opt/jderobot/setup.bash" .I changed the python path to "export PYTHONPATH=$PYTHONPATH:/opt/jderobot/lib/python3.5" from "export PYTHONPATH=$PYTHONPATH:/opt/jderobot/lib/python2.7" But still i am getting errors.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-01-22 03:40:38 -0500

aitormf gravatar image

Hi, Actually we haven support for python 3. There are things that work and others do not (for example, jderobot Ice Interfaces aren't generated for python 3.5), try to copy all contents from /opt/jderobot/lib/python2.7 to /opt/jderobot/lib/python3.5 and run

edit flag offensive delete link more
0

answered 2018-01-22 17:05:24 -0500

jmplaza gravatar image

Hi Pranav,

the whole JdeRobot project works only with Python-2.7. This decision was made to be compatible with ROS-Kinetic packages, as long as that ROS release they still remain in Python-2.7. There many things you can do with non-python components. Let's check that. Have you run the 1.1 and 1.3 examples?

About python problems, let's focus on the 1.4 example . Have you tried to run it with python2? For instance, after launching cameraserver as in the recipe,

cameraserver cameraserver.cfg

run:

python2.7 /opt/jderobot/share/jderobot/python/colorTunerpy/colorTuner.py colorTunerpy.yml

It works on my machine, where I have at the same time both python2.7 and python3.5...

edit flag offensive delete link more

Comments

I ran the the above instruction but it is showing the error "ImportError: No module named Ice" .I have installed Ice for python 2.7 but it is not showing for python2.7.It works for python 3.5. I think Ice does not support python 2.7.It is working error free for python 3.5

pranavk28 gravatar imagepranavk28 ( 2018-01-23 02:33:42 -0500 )edit

example 1.1 and 1.3 are running smoothly

pranavk28 gravatar imagepranavk28 ( 2018-01-23 11:27:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-18 10:58:46 -0500

Seen: 38 times

Last updated: Jan 22