Ask Your Question
0

Problem in installation of jderobot

asked 2018-01-18 10:57:31 -0500

pranavk28 gravatar image

I have been facing issues in installing Jderobot.I am mainly getting two errors

1)"ImportError: No module named Ice".This error is always showing when i try to compile with python2.7. 2)I am unable to run the python dependencies of jderobot with python3.5.I went to the following file "/opt/jderobot/setup.bash" .I changed the python path to "export PYTHONPATH=$PYTHONPATH:/opt/jderobot/lib/python3.5" from "export PYTHONPATH=$PYTHONPATH:/opt/jderobot/lib/python2.7" .But still i am getting errors.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-01-30 05:02:39 -0500

Hi @pranavk28,

Wich version of 'ICE do you have?. Actually, Jderobot works with python 2.7 and ice 3.6.X. You can install specific version of ICE by typing:

pip2 install zeroc-ice==3.6.3

It works on my machine. Try it and told me the results.

Regards, Nacho.

edit flag offensive delete link more

Comments

Requirement already satisfied: zeroc-ice==3.6.3 in /usr/local/lib/python2.7/dist-packages "ImportError: No module named Ice" .It is showing this error

pranavk28 gravatar imagepranavk28 ( 2018-02-01 07:54:40 -0500 )edit

It seems from the videoconf that this issue is already solved after a reinstallation on a clean machine.

jmplaza gravatar imagejmplaza ( 2018-02-16 12:12:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-18 10:57:31 -0500

Seen: 47 times

Last updated: Jan 30