Ask Your Question
0

Gazebo problem

asked 2017-12-28 13:21:07 -0600

reysam93 gravatar image

Hello all,

I have recently installed the last version of JdeRobot and its dependencies (Gazebo included), and I can't open some worlds, like kobuki-simple.world. When I try to open it I get the following error:

$ gazebo kobuki-simple.world Warning [parser.cc:527] Can not find the XML attribute 'version' in sdf XML tag for model: Ground Plane Transparent. Please specify the SDF protocol supported in the model configuration file. The first sdf tag in the config file will be used 
terminate called after throwing an instance of 'std::bad_alloc'

  what():  std::bad_alloc

I have also tried with the world kobuki-simple-ros.world and I gt another error:

$ gazebo kobuki-simple-ros.world 
Warning [parser.cc:527] Can not find the XML attribute 'version' in sdf XML tag for model: Ground Plane Transparent. Please specify the SDF protocol supported in the model configuration file. The first sdf tag in the config file will be used 
Warning [parser.cc:527] Can not find the XML attribute 'version' in sdf XML tag for model: simpleWorld. Please specify the SDF protocol supported in the model configuration file. The first sdf tag in the config file will be used 
[FATAL] [1514488507.570127674]: A ROS node for Gazebo has not been initialized, unable to load plugin. Load the Gazebo system plugin 'libgazebo_ros_api_plugin.so' in the gazebo_ros package)
[FATAL] [1514488507.574172551]: A ROS node for Gazebo has not been initialized, unable to load plugin. Load the Gazebo system plugin 'libgazebo_ros_api_plugin.so' in the gazebo_ros package)
[ INFO] [1514488507.620335985]: Laser Plugin: The 'robotNamespace' param did not exit
[FATAL] [1514488507.620510557]: A ROS node for Gazebo has not been initialized, unable to load plugin. Load the Gazebo system plugin 'libgazebo_ros_api_plugin.so' in the gazebo_ros package)
[FATAL] [1514488507.672541028]: You must call ros::init() before creating the first NodeHandle
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
[ERROR] [1514488507.678225834]: [registerPublisher] Failed to contact master at [:0].  Retrying...
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []

My gazebo path's configuration is the following:

echo $GAZEBO_RESOURCE_PATH/usr/share/gazebo-7:/usr/share/gazebo_models:/usr/share/gazebo-7:/usr/share/gazebo_models:/usr/share/gazebo-7:/usr/share/gazebo_models:/usr/share/gazebo-7:/usr/share/gazebo_models::/usr/local/share/jderobot/gazebo/models:/usr/local/share/jderobot/gazebo/worlds:/opt/jderobot/share/jderobot/gazebo/models:/opt/jderobot/share/jderobot/gazebo/worlds:/opt/jderobot/share/jderobot/gazebo/models:/opt/jderobot/share/jderobot/gazebo/worlds

Thanks!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-12-29 04:30:04 -0600

aitormf gravatar image

Hi Samuel,

you need use following commad to launch kobuki with ros:

roslaunch /opt/jderobot/share/jderobot/launch/kobuki-simple-ros.launch

those errors have occurred because gazebo don't find ros master

talking about kobuki-simple.world, can you put here gazbo verbose out messages?

gazebo -- verbose kobuki-simple.world

gazebo kobuki-simple.world works well for me

edit flag offensive delete link more
0

answered 2017-12-29 04:39:12 -0600

jmplaza gravatar image

updated 2017-12-29 04:44:51 -0600

Hummm, weird.... The XML warnings can be safely ignored. They also appear to me in my machine with the recently upgraded JdeRobot 5.6.2 package.

I've also launched the "gazebo kobuki-simple.world" and it works fine... sometimes. Others just fails.

With "gazebo kobuki-simple-ros.world" the same problems you reported also appear on my machine. The problem seems to be related to ROS plugins. Here has been also mentioned. I've not found any way to solve it yet.

Aitor, when launching gazebo in the verbose mode, I've seen these two warnings:

[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/pose/local/info, deleting message. This warning is printed only once. [Wrn] [msgs.cc:1808] Conversion of sensor type[depth] not supported.

But they appear both when Gazebo blocks and even when it works fine. When it fails, it shows (with no apparent cause):

[turtlebot] Shuting down Ice... [turtlebot] Ice is down now

edit flag offensive delete link more

Comments

with kobuki-simple-ros.world try to launch

roslaunch /opt/jderobot/share/jderobot/launch/kobuki-simple-ros.launch

aitormf gravatar imageaitormf ( 2017-12-29 04:54:17 -0600 )edit
0

answered 2017-12-29 06:33:47 -0600

reysam93 gravatar image

Thanks! The problem with kobuki-simple-ros.world is solved.

This is the output with verbose:

$ gazebo --verbose kobuki-simple.world Gazebo multi-robot simulator, version 7.9.0 Copyright (C) 2012 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Gazebo multi-robot simulator, version 7.9.0 Copyright (C) 2012 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Waiting for master. [Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.42 [Msg] Publicized address: 192.168.1.42 Warning [parser.cc:527] Can not find the XML attribute 'version' in sdf XML tag for model: Ground Plane Transparent. Please specify the SDF protocol supported in the model configuration file. The first sdf tag in the config file will be used terminate called after throwing an instance of 'std::badalloc' what(): std::badalloc

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-28 13:21:07 -0600

Seen: 380 times

Last updated: Dec 29 '17