Ask Your Question
0

JdeRobot dependencies problem

asked 2017-12-13 17:31:02 -0500

naxvm gravatar image

Hello, firstly I'm glad to be opening up the forum!

I've just fresh installed JdeRobot (5.6.1), and when I try to execute cameraserver, I get the following error, which I suppose is a dependencies issue. Does anybody know anything?

$ cameraserver
cameraserver: error while loading shared libraries: libopencv_videoio3.so.3.2: cannot open shared object file: No such file or directory

PD: actually, I only need the component cameraserver, but if I try to install only this component, I get another error:

$ sudo apt install jderobot-cameraserver-python
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jderobot-cameraserver-python

I have followed every previous installation step several times.

Thanks a lot! Regards,

Nacho

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-12-14 03:17:44 -0500

aitormf gravatar image

Hi Nacho,

jderobot-cameraserver-python package not exists yet. This component later than actual release.

the error with cameraserver is because we use ros opencv package and the are updated this package so this dependece is broken, we are preparing following release.

meanwhile you can install jderobot from source compilling only cameraserver

regards, Aitor

edit flag offensive delete link more

Comments

I was just going to ask for this same thing as I saw that there was an libopencv_videoio3.so.3.3 in the ros opencv package but not a 3.2. Thanks! Is there a date for the new release?

MikelDB gravatar imageMikelDB ( 2017-12-14 12:45:51 -0500 )edit

Hello Aitor, firstly thanks a lot for your answer. I'm not actually familiar about compiling the whole environment from source... In which point can I compile "cameraserver" exclusively, instead of everything? Again, thank you! Regards, Nacho

naxvm gravatar imagenaxvm ( 2017-12-16 16:22:51 -0500 )edit

Hi Nacho, you can compile only cameraserver, when you haver installed jderobot-deps-dev package and cloned the repository, using (in cloned repository):

mkdir build && cd build
cmake .. -Dbuild-default=OFF -Dbuild_cameraserver=ON

aitormf gravatar imageaitormf ( 2017-12-18 03:17:25 -0500 )edit

Mikel, the new release will be ready this week, we will notice you all when we lauch it. Sorry for the inconvenience.

fqez gravatar imagefqez ( 2017-12-20 08:53:01 -0500 )edit
0

answered 2017-12-19 05:31:59 -0500

naxvm gravatar image

Hello. Finally, I compiled everything from sources (thanks anyway Aitor for your answer to compile only cameraserver).

It works flawless now.

Thanks a lot, regards,

Nacho

PD: as a suggestion, maybe we should link on Community to this forum now, instead of the old mailing list.

edit flag offensive delete link more

Comments

Thanks for the suggestion, we've included a link to the forum.

fqez gravatar imagefqez ( 2017-12-20 08:51:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-12-13 17:31:02 -0500

Seen: 476 times

Last updated: Dec 19 '17