Ask Your Question
0

Problem with running cameraserver in virtual machines

asked 2018-03-17 04:21:18 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, I'm new to jdeRobot, and after installing packages to Ubuntu in VMWare(since currently I don't have a linux machine) I ran the first example in "Cameraserver + Cameraview" section in the tutorial page,

cameraserver cameraserver.cfg

It turned out that it gave me an error,

minori@ubuntu:~$ cameraserver cameraserver.cfg [Info] loaded Ice.Config file: /opt/jderobot/share/jderobot/conf/cameraserver.cfg URI: 0

!! 03/17/18 00:57:53.735 error: communicator not destroyed during global destruction.

and that was the same error as

http://answers.jderobot.org/question/...,

so I tried to change the video path to my webcam's one. However, I couldn't find my camera(integrated to laptop) in my virtual machine.

minori@ubuntu:~$ v4l2-ctl --list-devices

Failed to open /dev/video0: No such file or directory

I also searched some alternatives such as using Android phone as an USB webcam, but neither hasn't worked yet. I'd really appreciate if you could give me a suggestion... Any suggestion will be helpful. Shouldn't I use the virtual machine for this project?

Thank you for paying attention to this message!

Regards,

Miniori

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-03-20 05:56:21 -0600

fqez gravatar image

If you are using VMWare, in the toolbar select VM->removable devices->{your camera}-> connect (disconnect from host).

I don't know if this works with laptop integrated cameras, but it sure works for usb ones!

Hope it helps!

edit flag offensive delete link more
0

answered 2018-03-20 06:01:31 -0600

iarranz gravatar image

Hi @Miniori,

Have you tried allowing virtual box to use (in this case) the webcam? Normally it is to activate an option in: Devices --> Usb --> Webcam in VirtualBox.

Tell me the results so I can see if it worked for you.

Regards, Nacho.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-03-17 04:21:18 -0600

Seen: 40 times

Last updated: Mar 20