Ask Your Question
0

Installing JdeRobot on ubuntu 17.10

asked 2018-03-06 04:25:16 -0600

I tried following the steps in the installation page i changed this line deb [arch=amd64] http://jderobot.org/apt xenial main to deb [arch=amd64] http://jderobot.org/apt artful main and then after running sudo apt update i got this

Err:10 http://jderobot.org/apt artful Release
404 Not Found

i tried downloading the source code and compiling but that didn't work i got this -- Configuring incomplete, errors occurred! * ALUT not found -- Checking for one of the modules 'OPTIONAL;ardronelib' -- ardronelib NOT FOUND. -- Boost version: 1.62.0 -- Found the following Boost libraries: -- system -- filesystem -- thread -- chrono -- datetime -- atomic -- CUDA not found!! -- Checking for module 'eigen3' -- No package 'eigen3' found CMake Error at /usr/share/cmake-3.9/Modules/FindPkgConfig.cmake:412 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake-3.9/Modules/FindPkgConfig.cmake:588 (pkgcheckmodulesinternal) Deps/eigen3/CMakeLists.txt:1 (PKGCHECK_MODULES) Deps/LoadJderobotDependencies.cmake:12 (include) CMakeLists.txt:162 (include)

-- Configuring incomplete, errors occurred! See also "/home/karim/JdeRobot/CMakeFiles/CMakeOutput.log". See also "/home/karim/JdeRobot/CMakeFiles/CMakeError.log".

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-03-12 03:27:09 -0600

aitormf gravatar image

updated 2018-03-12 03:27:59 -0600

Hi Karim,

we only have support for 16.04. If you try to compile the project into 17.10, you will need compile qflightinstruments (qfi) and install our depencencies manually (ICE 3.6 and gazebo 7 obligatory because with new versions not compile). In this case you can forget ardronelib because it is only necessary for the driver of real Ardrone

edit flag offensive delete link more
0

answered 2018-03-12 03:29:11 -0600

jmplaza gravatar image

Hi, there is no packages prepared for that Ubuntu-17.10, only for Ubuntu 16.04 (LTS). We only prepare debian packages for Ubuntu LTS distributions.

You can work with dockers!, and run JdeRobot inside a container on your machine: there is a docker image with the last release of JdeRobot

In addition you can compile the source code on your 17.10. But this is a little bit tricky as JdeRobot has many dependencies (Gazebo, ROS, pcl, opencv...).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-06 04:25:16 -0600

Seen: 39 times

Last updated: Mar 12